New (old) Mac issues - frame rate lag at TCP/IP screen

intersilva

Member
Jun 5, 2020
41
46
18
Hello all,

I'm well aware that Mac users are on borrowed time anyway, so this may well be it, but I figured I'd post here and see if anyone has any input.

I'm running OS 10.14 Mojave on a 2017 MBP, I've been avoiding Catalina due to known compatibility issues with D2. Within the last month or so, I have lost the ability to play TCP/IP games, something I do on a semi-regular basis with a friend (it worked last time, about a month ago). The specific issue I am having is that my screen starts lagging terribly whenever I open the TCP/IP window. I can eventually maneuver the cursor over host or join game, and I have zero lag at the character selection screen, but again once in the game I still have the same incredibly low frame rate, making the game entirely unplayable.

This is only an issue with TCP/IP. I can still play my characters solo and play on b.net no problem. I had this issue for a while in the past, and it resolved itself. I attributed it to something having to do with Mac software updates, and since my computer installed a fairly large update recently I figured that was the culprit. My older 2010 MPB still running High Sierra 10.13 does not have the same issue (though it has other issues, which is why I am trying to play on the 2017).

Any help would be greatly appreciated. Thanks in advance!
 

maxicek

Moderator
Staff member
Dec 24, 2019
686
645
93
So it lags before you have even pressed join game?

is this with the Mac client?
 

intersilva

Member
Jun 5, 2020
41
46
18
Correct, it lags on the join/host screen and in game. And yes, this is with the Mac client, only on my fully updated machine. The machine running High Sierra is running it fine, though the machine with Mojave was also fine about a month ago.