• These forum archives have been curated by the community bringing two decades of Diablo 2 knowledge to new players. They are purely for reference and cannot be posted in. Use the main PureDiablo forums for all new conversation.

old or new bug?

Jul 8, 2003
868
0
165
Boston, USA
old or new bug?

Okay, I was playing my Gifts from Above barb, opened up my character screen, and saw that I had maxed fire/cold/lightning resists (75 each). This did not seem right to me, since I was sure that my fire resist was NOT maxed out.

I started taking off my gear and charms, and saw that my fire/cold/lightning resists seemed to have gotten mysterious bonuses from somewhere. It was NOT from Natural Resist, because my natural resist has 1 point in it (+12 resist all) and the invisible bonus seemed to be around +30 to all (except poison).

I exit the game, immediately create another one, and voila, my barb's resists were down to where they should have been (proving that the bonus from before was a bug).

Notes:
-I did not have a skill shrine active when I noticed the resistance bonus. I did, however, click a skill shrine earlier in that game.
 

Death_StrikeR

Member
Jun 23, 2003
307
0
78
Philippines
are you sure you removed all your equip on him?
maybe you have missed a ring or amulet ^_^

Anyways, you character is already fine now, so.. no need to worry...

I don't think anyone here had experienced what you had.

cheers!

/davedexterz
 

lone_wolf

Member
Jun 25, 2003
3,071
0
255
39
sweden
well you said you had 1 point in nat res that is 12 all res a skill shrine boosts you skills with 2 bumping up that 1 point 12 res all natural resists to 3 point 28 res all. That is the most likely explonation atleast
 
Jul 8, 2003
868
0
165
Boston, USA
lone_wolf said:
well you said you had 1 point in nat res that is 12 all res a skill shrine boosts you skills with 2 bumping up that 1 point 12 res all natural resists to 3 point 28 res all. That is the most likely explonation atleast

I definitely did not have a skill shrine active at the time I checked my resists. It was like the +2 to nat res stayed with me well after the skill shrine expired. Like, ten to fifteen minutes after.

Death_StrikeR said:
are you sure you removed all your equip on him?
maybe you have missed a ring or amulet ^_^

I'm absolutely sure I removed all equipment from him when the bug happened. And as I said, the buggy bonus went away when I exited and created a new game. This proves the bonus wasn't coming from my equipment.

I'll try to duplicate the bug. Hopefully I can find another skill shrine...
 

essojay

Member
Jun 26, 2004
2,583
0
120
NH
Don't expect much accuracy from the LCS.

edit: changed LCR to LCS :lol: thanks wolf
 

lone_wolf

Member
Jun 25, 2003
3,071
0
255
39
sweden
well if you sure it had expired then by all means try to recreate it. if it works again you have indeed found a new 1.11 bug:)

essojay did you mean LCS as in Lying Character Screen or is LCR something new?
 

Harleyquin

Member
Apr 12, 2005
339
0
122
Have you factored in the bonus from Anya's quest? Many people forget about the resistance scroll bonus.
 
Jul 8, 2003
868
0
165
Boston, USA
Harleyquin said:
Have you factored in the bonus from Anya's quest? Many people forget about the resistance scroll bonus.

Yup, factored it in.

I just duplicated the bug...it definitely happens when my barb clicks a skill shrine for the first time during a single player 1.11 game.

As expected, his resists go up because of the +2 to Natural Resistance, but the bug is that all his resists stay at that level after the skill shrine has expired. If a second skill shrine is clicked after the first one has expired, there is no effect on resists (since they are already at elevated levels)
 

Insane Wayne

Member
Oct 19, 2003
1,418
25
123
Chicago
Visit site
I've experienced a similiar display bug that affects AR. Visit a skill shrine, and your AR gets boosted. When the shrine wears off, the displayed AR retains the bonus. I recall placing a skill point in Penetrate, and watching my AR go down (because it reset the LCS.)
 
Jul 8, 2003
868
0
165
Boston, USA
Insane Wayne said:
I've experienced a similiar display bug that affects AR. Visit a skill shrine, and your AR gets boosted. When the shrine wears off, the displayed AR retains the bonus. I recall placing a skill point in Penetrate, and watching my AR go down (because it reset the LCS.)

Ah, now I see what essojay was talking about.

I guess maybe I put too much faith in the LCS? Well, is there any way to test whether it is a display bug or a real bug?
 

Tarr

Member
Jul 8, 2003
467
0
143
Chances are that it's just a display bug and nothing else. If a SC character dies in 1.10, for the rest of that game, they lose their bonuses from resistance scrolls, though the character screen shows them as just fine. I'd be willing to bet that your resists are actually correct and that the display is just wrong.

Also, keep in mind battle command, if that's on, that's another +1 to nat resist.
 

Insane Wayne

Member
Oct 19, 2003
1,418
25
123
Chicago
Visit site
I agree it's probably just a display glitch. You can test it by standing in the aura of a Holy Shock/Fire/Freeze boss, and noting the damage you take. I've noticed the damage is very consistent each pulse. Then get your skill shrine, wait for it to wear off, and return to the same boss. It would be easiest to see with low resists and low-level NR, against a Hell boss.